Jump to content

Idle raises when I put it in gear.

Recommended Posts

2016 yz250x, I retarded the timing today at .004 or 1 degree ,also installed nedj needle on clip 2 cause necj was a little fat on 3rd clip,went back to a 50 pilot because I was getting a hanging idle with the 48 and wanted to play it safe going a half step leaner,170 main.after I got everything back together I started it and everything seems normal,let it warm up to 150 and put it in gear and my idle jumped up a little, put it back in neutral and idle went back down tried it again same deal.its not raising much maybe a couple hundred rpm but it's never done this before.the jetting is really good I finally got it to pull the front tire thru 3rd without effort.plug looks good after a throttle chop.couldnt find anything like this by searching.anyone else seen or heard of this.leakdown test is perfect.thank u

Share this post


Link to post
Share on other sites

2016 yz250x, I retarded the timing today at .004 or 1 degree ,also installed nedj needle on clip 2 cause necj was a little fat on 3rd clip,went back to a 50 pilot because I was getting a hanging idle with the 48 and wanted to play it safe going a half step leaner,170 main.after I got everything back together I started it and everything seems normal,let it warm up to 150 and put it in gear and my idle jumped up a little, put it back in neutral and idle went back down tried it again same deal.its not raising much maybe a couple hundred rpm but it's never done this before.the jetting is really good I finally got it to pull the front tire thru 3rd without effort.plug looks good after a throttle chop.couldnt find anything like this by searching.anyone else seen or heard of this.leakdown test is perfect.thank u


Also 58 degrees f,200ft elevation.

Share this post


Link to post
Share on other sites

The YZ has had the neutral switch for a while. I don't ever remember one exhibiting that behavior. Must be in the CDI programming? Anyone who put an X CDI on there YZ all of a sudden experience this behavior?

Share this post


Link to post
Share on other sites

2016 X here as well... Same deal, just a timing/CDI change when it goes into gear.

Share this post


Link to post
Share on other sites

One of my favorite things on the X. Overrides the clutch drag in gear without a high RPM in neutral.

Obviously no change on my 2000 with X CDI as it has no neutral sensor.

  • Like 2

Share this post


Link to post
Share on other sites

Was googling higher idle in gear and came across this

Sorry to bring back an old thread,

I just noticed this for the 1st time on my 2016 YZ250X After put in NEDJ 3rd clip 45PJ 170MJ, 

Now it might have done it before but am not sure lol

So its nothing major to worry about

Edited by Edward05
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×