Jump to content

Recommended Posts

I have a 2008 Kawasaki   KF250F  that I recentlly bought. It idles great. Off the line it has lots off power, but if i'm hold 1/4- 1/2 throttle in third just going down the road it feel like it missing ( new spark plug though)  or sputtering.  Full throttle has no problems.  

Maybe to much gas in the early mid range of accelleration

The bike has a full FMF exhaust with the Power Bomb header

It had a stock jet kit and i just replace it with a new factory set, but a larger main jet. Playing with the main jet has very little effect. Maybe to rich when it opens more, get a couple backfires.

Anyway, bike runs worse now.. They left the needle position the same. Wondering if that could be the problem

I have ordered the FMF Power Up Kit, But wonder about the pilot jet setting. 

I really have no experience with jetting

 

Thanks

Share this post


Link to post
Share on other sites

First, you have to bring the bike back to stock specs:

Valve adjustment

Pack the silencer

Replace the worn components in the carb: *emulsion tube, slide plate seal, fuel screw oring

 

* if you replace the emulsion tube (needle jet), put in a fresh fuel screw oring, and set your valve clearances, you will probably be running fine.

There is NO REASON to change jetting if it ever ran well with the jetting it has now..........

 

  • Like 1

Share this post


Link to post
Share on other sites

Valves were good. I'm a new rider so I didn't really notice the missing or sputtering.  When I'm on the track it seems fine, but I'm on it pretty hard all the time.  I notice the sputtering when i was riding straight down the road at 1/4 - 1/2 throttle.

I was told by the shop it should have been jetted when the FMF header and muffler were put on.

There are going to moving the needle up or down a notch(can't remember).  They think that will fix it.  If not, I'm going to buy a FMF Power Up kit.

Thanks

Nice Vizsla !

Share this post


Link to post
Share on other sites
1 hour ago, DUG7522 said:

Valves were good. I'm a new rider so I didn't really notice the missing or sputtering.  When I'm on the track it seems fine, but I'm on it pretty hard all the time.  I notice the sputtering when i was riding straight down the road at 1/4 - 1/2 throttle.

I was told by the shop it should have been jetted when the FMF header and muffler were put on.

There are going to moving the needle up or down a notch(can't remember).  They think that will fix it.  If not, I'm going to buy a FMF Power Up kit.

Thanks

Nice Vizsla !

The FMF kit is junk.  None of the jets are flow tested.

Use only JD Jetting or Keihin jets or you will have issues.

Share this post


Link to post
Share on other sites

moving the needle down will fix it by making it leaner during partial throttle

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×