Jump to content

Problems installing sicass blinker handguards on '17

Recommended Posts

Wondering if anyone had any ideas of what might be going wrong with my install.  Here's the story:  I have a '17 500EXC.  I replaced the rear taillight/turnsignals some time ago with one of the integrated led units that a guy sells on ebay.  Really nice unit btw.  Everything worked fine with the stock flasher and stock front turn signals with the exception of them flashing slightly faster.  I purchased the sicass integrated turn signals/handguards and their sicass led flasher.  When I installed these, now using the turn signal switch causes all of the turn signals to flash simultaneously like hazards.  I put the stock turn signals back on and used the sicass flasher.  Back to normal.  Putting one handguard flasher on makes that side work fine but when the other side is selected, back to flasher mode.  Any ideas what might be going on.  I wasn't expecting to get stumped on such a simple project.

Share this post


Link to post
Share on other sites

I had the same problem. There's diodes in the yellow wye. Sounds like one of them shorted out. Try unplugging the wye and see if it works. If it does there's a problem with one of your diodes. I found this out by speaking with the guys from sicass.

 

Share this post


Link to post
Share on other sites

I think I may have figured it out by searching through the sicass website.  Sounds like somehow the flasher indicator light on the dash causes the problem with all led setups.  The options are to disconnect the indicator light or buy a wiring adapter from them that rewires the indicator light.  It looks like the wire kit has a new wye in it which must have different diodes in it similar to what disturbenz was talking about.  for $7 I'm going to give that a try and see if that is the fix.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×