Jump to content

2014 450 XCW LIGHT THROTTLE STUMBLE

Recommended Posts

I'm having a strange issue with my FI 450.  At very light throttle, thing tooling down the road on a dual sport, it will stumble, like it misfires for a single revolution.  As soon as you get into the throttle more it's fine, runs STRONG.  The exhaust tip is CLEAN, like it's running really lean somewhere, but it's always been a clean running bike.  Where do I look?

Motor/exhaust/map all stock save for TPS at .64v

310 hours, valves never moved.  Fuel pump filter replaced at 150 hours.

PS.  it is taking longer and longer to start, but if I let the pump prime first, then give it another shot, it fires up instantly, as if the pressure is being bled off too quickly (stuck regulator?).  Could be related?

Overall, it still runs like a scalded dog though!

Share this post


Link to post
Share on other sites

For the starting issue check the valves if you haven't recently.  If they're starting to tighten up then that could start to affect starting.  

Regarding your TPS, read this review involving an XCW.  It addresses what I think is the same issue you are having:

https://www.thumpertalk.com/reviews/product/43103-tps-tools-throttle-position-sensor-adjustment-tool/
 

Share this post


Link to post
Share on other sites

Valves are good to go, checked them less that 10 hours ago.  Problem has persisted since before that.  I'll take a look at the article...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×