Jump to content

Throttle and idle issues

Recommended Posts

So I just checked and adjusted the vavles in my 2007 kx250f I also replace the pilot jet with a new 40 jet and a new fuel screw. My problem is when the bike is running it wants to idles high. When I start it it will idle at about 3500 if I push the hot start in then the rpms go down to around 2000. When they are at 2000 and I touch the gas their is a slight bog and the rpms stay at 3500-4000rpms. Hit the hot start and it come back down. Their is also a pretty back backfire. I ride at about 250-1500 altattude from 65-90 degree weather. Any suggestions? 

Share this post


Link to post
Share on other sites

Before can help you, may you please review what you are describing as is the problem and edit so it is clear. For example "if I push the hot start in" isn't clear.

The hot start is a short finger pull lever on the clutch lever post. The choke is a smooth black pull/push plunger on the upper left side of the carb. The idle speed set screw is black knurled knob on lower left side if the carb. The fuel screw is in the bottom of the carb in a hole through the front of the float bowl.

So what is the problem and what have you adjusted and what happened?

 

 

Share this post


Link to post
Share on other sites

I have replaced all of the vavles the needle all washers I just today replaced the fuel screw with longer tusk screw. I lubed the throttle cables and housing. My hot start is a push lever next to the couch hadle in which I "push" in. 

I beleave it was a 40 pilot and a 182 main jet. 

Share this post


Link to post
Share on other sites

I had already adjusted fuel screw out but seems to be running way to lean so I have it turned in all the way in to try and richen it. I plan on changing the pilot to a 42 and seeing if that helps. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×