Jump to content

2016 Xtrainer starter problem

Recommended Posts

I had an issue a while back where my ignition cover cracked, a bunch of water got sucked in and fried my stator.  I replaced the cover, replaced the stator, and got it back up and running.  While I had it apart I cleaned everything, soaked the bendix in oil, and put 20cc of fresh oil in the side cover as my dealer recommended.  Ever since I put it back together the starter has been less and less reliable.  Sometimes it sounds like the bendix doesn't engage at all and just spins, and sometimes it engages but will barely turn.  I've tried a few different batteries that I know are good but it doesn't make a difference.  I pulled the bendix out and it sticks a little bit when I spin it by hand, but I'm not sure that would cause the problem I'm having.

Has anyone had a similar problem?

Thanks

 

Share this post


Link to post
Share on other sites
1 hour ago, benJAZDirtRider said:

I had an issue a while back where my ignition cover cracked, a bunch of water got sucked in and fried my stator.  I replaced the cover, replaced the stator, and got it back up and running.  While I had it apart I cleaned everything, soaked the bendix in oil, and put 20cc of fresh oil in the side cover as my dealer recommended.  Ever since I put it back together the starter has been less and less reliable.  Sometimes it sounds like the bendix doesn't engage at all and just spins, and sometimes it engages but will barely turn.  I've tried a few different batteries that I know are good but it doesn't make a difference.  I pulled the bendix out and it sticks a little bit when I spin it by hand, but I'm not sure that would cause the problem I'm having.

Has anyone had a similar problem?

Thanks

 

There was this thread: 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×