Jump to content

PLEASE HELP CORROSION ON HEAD WORRIED !!

Recommended Posts

Ignore the gouges in the piston that was done after the corrosion of the head was found 

Share this post


Link to post
Share on other sites

That looks like detonation.

I bought a YZ125 that looked like that, the kid I bought it from was running a SST pipe on pump gas.

Eric Gorr said the result was from detonation, He turned it into a 144 for me.

Edited by Treesmacker
  • Like 3

Share this post


Link to post
Share on other sites

I'm talking about the jug and head corrosion the marks in the piston are from me stabbing it when I found the corrosion 

Share this post


Link to post
Share on other sites
10 minutes ago, Alcorn859 said:

So what did I do wrong ? And how do I fix this ? 

Retard timing or use Race Gas.

Share this post


Link to post
Share on other sites

How do I get this fixed ? I was installing new piston when I discovered this... and decided to jam a flat blade screw driver in the piston when I saw it haha 

Edited by Alcorn859

Share this post


Link to post
Share on other sites

Head is cut ! And I only took this motor apart for inspection and found this corrosion I was using pure race gas. 

Share this post


Link to post
Share on other sites
30 minutes ago, Alcorn859 said:

Yes head is machined

is it a yz250? you previously had it machined for specific application (mx, offroad, gas type)? what is your timing set at?

Share this post


Link to post
Share on other sites
18 hours ago, Alcorn859 said:

So what did I do wrong ? And how do I fix this ? 

For grins,  lift up the orings and take a pick and show them please.  what is your history with this engine?   Did you put the last piston in it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×