Jump to content

Rebuilt Top End. Has Too Much Compression

Recommended Posts

Alright guys. I have a 05 Kx250f. Bike ran pretty good, but smoked and ticked just a tad. So decided to put in a new piston and gaskets and adjust the valves. So after putting everything back together I realized that it was super hard to kick over, It has wayyyy to much compression. You can kick it over but not fast enough to start it, Ive started cr500's and its way more than those have. When I had it tore down the crank was good with no play. So since I couldn't start it by kicking it, I tried to roll it off and eventually it did start but it sounded like crap and it was either ticking or knocking pretty bad. But it ran fine before. And now also the oil mixes with antifreeze instantly and looks like eggnog. Im thinking either wrong gaskets or something like that. Possibly wrong piston. Any help would be great. (Also I checked valve clearances and there good)

Share this post


Link to post
Share on other sites

If you have oil mixing with the gas  you may be getting coolant into the cylinder,  thus making it harder to kick over.  Something has gone wrong with your build at any rate.

Share this post


Link to post
Share on other sites

Im thinking maybe a bad waterpump. I tore it back apart and there was antifreeze all in the cylinder and on top of the piston and inside the head. So im thinking maybe the water being inside the cylinder is causing it to be hard to kick maybe?

 

Share this post


Link to post
Share on other sites

Perhaps. Or you were supplied with wrong piston and it is contacting the head. That contact knocking the top and popping the gasket loose, letting coolant/ oil to mix.

Your only fix is to open it to see whats going on. Look for contact marks on the head or piston or valves. Check the exhaust cam decompressor is working properly. Compare the new piston to the old. Measure the distance from piston crown to the wrist pin.

 

 

 

Share this post


Link to post
Share on other sites

3 posts in 9 months - hasnt been on since june 7 - good luck with a progress report

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×