Jump to content

Headlight trouble

Recommended Posts

Having trouble with my headlight, but I think its a symptom of something bigger.  

A little background, the bike has had a bunch of charging and battery issues.  Replaced the stator last year and still have trouble with batteries not a charging.  super frustrating...

My headlight was out for who knows how long so I put a meter on it and 0v.  I traced the wires and found whenever I raised the rear supreme last that connector close to the back pulled apart.  Plugged it back in and have around 6v at idle and twisting the throttle makes it go to 12v.  Bulb was burnt, so I got a new one.  Put it in and seemed to work in the garage for a second.  When I started the bike to ride and twisted the throttle hard a few times I noticed the light was out.  I looked closer and the bulb had shattered.  Maybe an over voltage situation?  Is this why my batteries aren't charging properly??  

I searched on here a bit is there a regulator somewhere thats gone bad???  I looked on motorsport for the part but didn't see it.  What should I do next???

 

thanks:)

 

 

Share this post


Link to post
Share on other sites

Might be wrong but I think there should be a rectifier to keep the voltage at a constant rate

  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, Bbarker71 said:

Might be wrong but I think there should be a rectifier to keep the voltage at a constant rate

I'm thinking that too.  I was hoping to look online and find an oem part I can just swap out. easy peasy.  But all I see are rectifiers you can add that need a different stator???  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×