Jump to content

XR 650L intermittent bog problem. Help please.

Recommended Posts

Hi,  ive revently bought a 2005 650L. It needed rejetting. Ive desnorkeled it and desmogged it aswell. It ran really well for a while. Recently, it started to bog. Its still running really well most of the time, but there and there, it die. It will restart, but die as soon as I give it throttle. Then everything is fine for a while. 

I also notice that it sometime, intemittently, bog down low, but without dying. Seem like a really lean condition, but my jetting is alright.

Its happening more and more often.

Ive ordered a new CDI. Any other thing I should check for?

Share this post


Link to post
Share on other sites

Turn the petcock off and open the drain screw on the carb , let it drain. Turn the gas back on until gas comes out again and close the drain screw. It sounds like debris in the float bowl intermittently getting sucked into a jet a then dropping back out. Often this will flush it out.

Share this post


Link to post
Share on other sites

Did you replace the short pilot jet with a long one? The long one is fine but the slosh baffle can move around and partially block it, trimming the baffle on mine fixed this.

Share this post


Link to post
Share on other sites
4 hours ago, XR650L_Dave said:

Did you replace the short pilot jet with a long one? The long one is fine but the slosh baffle can move around and partially block it, trimming the baffle on mine fixed this.

The one I putted in was the same as the one I took out. Im not sure what kind it is. Good info though. Did the a ride today and it was fine. Will replace the cdi, then explore that if the bog is still there.

Share this post


Link to post
Share on other sites

So yeah. I changed the CDI and it was not the issue. I will explore the carb and try to see if its not a slosh baffle issue... can you just remove it?

Share this post


Link to post
Share on other sites

I think ive found the issue...when I rejetted the bike, I used a scotch tape to hold the float up while I was changing the jet. Long story short, I forgot to remove it. Its was in the bowl. Probably intermittently block the jet...sorry for the trouble guy

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for sharing. Glad you got it sorted out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×