Jump to content

TTR125 not working

Recommended Posts

I have a TTR 125 that has suddenly decided to stop working. It was working almost perfectly until I put new gas into it, since I had run out. Then, it decided to stop working. I cleaned the carburetor out to see if that would fix it, but it didn't. (I have a Mikuni VM24 that I put on since the stock carburetor wouldn't idle). I cleaned the spark plug, but that didn't do anything either. Then, I went to the store and bought new spark plugs, but still that only helped a tiny bit. The new plug made it so that I could bump start it in fourth gear, but I would have to have the throttle almost all the way pinned to get any revs or power. I drained the gas and put new gas in, to see if there was any water in it, but that still did nothing. Just today, I cleaned out the old factory carb and fixed the problem that was causing the idle to not work, but still, NOTHING. I checked the valves, and they are perfectly aligned. I have no idea what is going on with this bike, and I need help very badly, because I am trying to sell it so that I can upgrade to a 250. 

Share this post


Link to post
Share on other sites
I have a TTR 125 that has suddenly decided to stop working. It was working almost perfectly until I put new gas into it, since I had run out. Then, it decided to stop working. I cleaned the carburetor out to see if that would fix it, but it didn't. (I have a Mikuni VM24 that I put on since the stock carburetor wouldn't idle). I cleaned the spark plug, but that didn't do anything either. Then, I went to the store and bought new spark plugs, but still that only helped a tiny bit. The new plug made it so that I could bump start it in fourth gear, but I would have to have the throttle almost all the way pinned to get any revs or power. I drained the gas and put new gas in, to see if there was any water in it, but that still did nothing. Just today, I cleaned out the old factory carb and fixed the problem that was causing the idle to not work, but still, NOTHING. I checked the valves, and they are perfectly aligned. I have no idea what is going on with this bike, and I need help very badly, because I am trying to sell it so that I can upgrade to a 250. 

Does it get any spark at all?

Share this post


Link to post
Share on other sites
Just now, FSK_Talon3 said:


Does it get any spark at all?

Yes, it does get spark.

Share this post


Link to post
Share on other sites
Yes, it does get spark.

I thought about it after I said it. You said it bump starts so dumb question on my end. Is it a real VM24?

Share this post


Link to post
Share on other sites
Just now, FSK_Talon3 said:


I thought about it after I said it. You said it bump starts so dumb question on my end. Is it a real VM24?

I bought it off of ebay, so there is the chance it isn't real.

Share this post


Link to post
Share on other sites

Does it pop? The intake could be ripped.  I used to rip mine all the time from taking carb on and off so much.  If it is, grind all the rubber off and use radiator hose with two clamps.  Works great.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×