Jump to content

Yamaha PW80 Please help!!

Recommended Posts

I have had a Yamaha pw80 for about 13 years now and for the last 5 years it has just sat in my garage collecting dust. Well about a month ago I pulled it out so I could enjoy it again but of course needed normal maintenance and fixing up. Replaced old gas, oil, and spark plug, took the entire bike apart and cleaned it. Got a new carb just because last one was very old and they aren't expensive and replaced all of the lines. Well now the thing takes literally 20 cranks to start if I'm lucky. As of right now I have the air box off. When I start it, it will run for a short amount of time and then stop. It runs longer or shorter times at random. I could do it and it could go for about 4 seconds then quit or it could go for about 20 then stop. Also, when I put it in gear it immediately dies like its starving for gas but it's a new carb like 3 days old. Tried adjusting the 2 knobs on the carb to get different idle speeds and air/fuel ratio. Nothing really seems to work. Like I said earlier, new gas lines. About to get new kill switch because mine is broken where the throttle cable comes into it so my throttle is just loose but the bike should still idle without it if I'm not mistaken. About to get a new piston kit and gas tank valve to see if the valve isn't allowing enough gas flow. So please help as much as possible because I've tried everything I know and nothing's working so far and it's kind of getting annoying. I have videos of what it's been doing. Also, keep in mind that I am new to this motor and bike stuff so basically dumb everything down for me. Thanks everyone!!

Share this post


Link to post
Share on other sites

When you installed the new carb, did you set the float bowl height, adjust the air screw, etc or just clamp the carb on and hope for the best? I would start with the float and verify the height is correct. This of course is assuming that you have a good fuel flow through the hose and to the carb.

Share this post


Link to post
Share on other sites

I didn't know anything about the float bowl height and don't know how to adjust it but did adjust my air screw over and over and it won't stay running

Share this post


Link to post
Share on other sites

Okay... well same thing happening. Did the float level multiple times. If possible I would like to know how to get it started sooner than 29 something times

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×