Jump to content

Replace this water pump shaft or not?

Recommended Posts

Rebuilt entire motor, last thing to do is put the side cover on. This is my water pump shaft. My oil is usually dark gray or black and I'm not losing any coolant. I have a seal kit if you guys think I should just change those and run it. IMG_0207.JPG only wear that seems bad is this shoulder thing but isn't that supposed to be like that? IMG_0209.JPGIMG_0210.JPG

Share this post


Link to post
Share on other sites

Might be able to polish it a little with some 600grit and be ok...tough to tell without holding it in my hands. Personally, if you can FEEL the wear as you run your fingertip or nail along it and it feels substantial, I'd bite the bullet and replace it.

Share this post


Link to post
Share on other sites
10 hours ago, BTYZSquad said:

 

Rebuilt entire motor, last thing to do is put the side cover on. This is my water pump shaft. My oil is usually dark gray or black and I'm not losing any coolant. I have a seal kit if you guys think I should just change those and run it. IMG_0207.JPG only wear that seems bad is this shoulder thing but isn't that supposed to be like that? IMG_0209.JPGIMG_0210.JPG

 

Center section is not on a seal lip. Part that rides between seals. If there is any corrosion on the impeller side replace, if any grooves, replace. Otherwise you can put it in a drill and use fine steel wool buff it up and inspect again. If you have 50 bucks, buy a new one and forget about it. 

Can't tell you how bad it is, I don't have it in my hands either. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×