Jump to content

knocking sound 2009 kfx450r

Recommended Posts

Hey guys?? I recently took my atv out to go riding and while I was out on the track I went down this straight away and the bike just shut off on me. Tried to start it back up and it sounded like something was knocking on engine and it wouldn't start. 

 

 

Edited by blumotos

Share this post


Link to post
Share on other sites

Does it still have compression? If so its the crank bearing, if not you probably dropped a valve and now you have a window in the top your piston.

Share this post


Link to post
Share on other sites

I would tear the top end down and check the piston for marks from the valves, or even a broken piston. This doesn't sound too bad, considering other possibilities. Did someone either recently adjust the valves or maybe never adjusted them?

The modern day 4 stroke engines make a lot of usable power, but they do require more maintenance and servicing can get costly when comparing to the old 2 stroke engines.

Share this post


Link to post
Share on other sites
On 6/18/2017 at 10:33 AM, NYMXer said:

I would tear the top end down and check the piston for marks from the valves, or even a broken piston. This doesn't sound too bad, considering other possibilities. Did someone either recently adjust the valves or maybe never adjusted them?

The modern day 4 stroke engines make a lot of usable power, but they do require more maintenance and servicing can get costly when comparing to the old 2 stroke engines.

Well... I went to go change the oil filter and it was on backwards?‍♂️ The engine was probable starving for oil and that's what probable caused this sound but I still don't know where it's coming from. 

I took apart the whole top end and checked everything. Cylinder, piston, valves etc... and everything is in speck and looks nice. 

Share this post


Link to post
Share on other sites

Sounds like you got very lucky, I am glad you got it sorted out without breaking the bank. Now, go ride that thing and have fun!

Share this post


Link to post
Share on other sites
10 hours ago, NYMXer said:

Sounds like you got very lucky, I am glad you got it sorted out without breaking the bank. Now, go ride that thing and have fun!

Actually didn't get very lucky at all... I found out that the noise was a bent crank rod and a messed up crank and bearings?. A whole top and bottom end rebuild is on its way with a 470 kit. There goes the 1,300 dollars I was gunna spend on a full suspension mountian bike...

Share this post


Link to post
Share on other sites

Ouch, but glad you finally have a solution to the problem. BTW. $1,300 will not buy a decent FS Mtb... just saying and hoping that you don't get disappointed again

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×