Jump to content

Klx 140 high pitched worn bearing type of noise coming from engine

Recommended Posts

I recently bought a klx 140 from someone, had no problems the first day I rode it. I changed the oil and filter, then took it out the next day for another ride.

after the bike is warm and you stop riding there is a sound that sounds like a wheel bearing going bad coming from the engine area. The sound isn't noticeable while riding but is very noticeable while idling after it's been ridden for a few minutes. 

I checked the oil level and it's good. I'm finding it hard to find any information on this type of noise. Anyone have any ideas? My fear is the rod bearing is toast and needs replaced, but I'm not too familiar with these engines yet.. my experience isn't in the car world and fuel injection haha.

Share this post


Link to post
Share on other sites

Can you locate the source of the sound? Most bottom end sounds stay in the bottom end. The chain for the timing can grind if the tensioner is loose. Check the free play of the timing chain first. Are any bolts non stock? Sometimes replacement bolts are slightly too long and make contact inside where they shouldn't. Take note of anything thats been replaced and back it off a little to see if the noise goes away. Look on the side to see if the oil goes away when running or stays at the level it is when not running. You may have oil starvation and not be lubricated properly. Could be time for an oil pump. Those are some simple checks for more serious things without taking it apart yet. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×