Jump to content

2017 wr450f driving me mad!

Recommended Posts

Ok time for the experts to chime in.......

Couple months ago me and a buddy went out and bought two brand new 2017 wr450f same dealership same day. Both bought the Ryco street legal kit and we did the install ( both of us mechanics by trade ) bikes have roughly 200 miles on them. The bikes keep blowing the main 15A fuse by the battery. i have slowly upped the fuse and have put a 30a in it and it still pops! this problem is progressively getting worse! i have noticed it the worst when riding single track and lugging the bike in first or second gear really slow. basically if i run up fast into a hairpin corner and chop the trotttle and get back on it almost from a dead stop pop there goes the fuse and the bike dies. trail was 15 miles yesterday i wet through 8 fuses and barely made it back to the truck. running around town and wide open in the desert area never a problem only riding slow! both bikes are doing the same thing! what gives? only thing i can think is the RYCO street kit is causing this surge in power? i don't run with the headlight on ever. i am so irritated and after yesterday i can trust the bike to get me back from the mountains. i have googled my butt off and cant find anything related to these new wrs. any help and direction would be great! thanks guys. 

Share this post


Link to post
Share on other sites

Sounds like you have a short somewhere in the Ryco add-ons. I would start unplugging things one at a time and ride until the fuse pops again. I would start with the brake switch. Good luck!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×