Jump to content

Starting issue

Recommended Posts

So guys My bike wouldn't start unless bumped so I took it to a specialist and they checked my timing and it was completely off so he corrected it. Now there's a lot of compression as well as backfiring but still doesn't want to start. What next can I check?

Share this post


Link to post
Share on other sites

2009 model. Checked the injectors and cleaned them. Have put in a new spark plug

Share this post


Link to post
Share on other sites

Check the timing again, sounds like it has jumped a tooth again. Replace cam chain and tensioner if it has.

  • Like 2

Share this post


Link to post
Share on other sites
Check the timing again, sounds like it has jumped a tooth again. Replace cam chain and tensioner if it has.


Ye just messaged my mechanic and he had already decided to check the timing again so he will do that tomorrow and let me know, I'll keep you updated cheers though buddy

Share this post


Link to post
Share on other sites

Worn/stretched timing chain and possibly need a new timing chain tensioner. I would advise replacing the guides while it is apart. Lookin at about 150 in parts. Replace everything before you grenade that top end man.

Share this post


Link to post
Share on other sites
Worn/stretched timing chain and possibly need a new timing chain tensioner. I would advise replacing the guides while it is apart. Lookin at about 150 in parts. Replace everything before you grenade that top end man.


Alright bud going to pop over to the shop quickly
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×