Jump to content

2012 WR450 VS 2015 WR450


Recommended Posts

Help me please , I have a WR 450f 2013 model , all serviced n ready to go road legal been out on it about 8 time rides well lots of power , but lately it's been acting it's self had the valve clearances checked they fine , rides good for the first half hour then when it is hot it starts to splutter like as if it's not getting enuff fuel or sumit just not rite I've had it looked at in my local garage carnt seem to find the problem ,sometimes it's ok for just ten mins the sometimes nealy a hour , it's happens when it's hot but the valve clearances seem to be ok , pls any ideas what this could be ????

Link to comment
Share on other sites

29 minutes ago, Neil Haley said:

Help me please , I have a WR 450f 2013 model , all serviced n ready to go road legal been out on it about 8 time rides well lots of power , but lately it's been acting it's self had the valve clearances checked they fine , rides good for the first half hour then when it is hot it starts to splutter like as if it's not getting enuff fuel or sumit just not rite I've had it looked at in my local garage carnt seem to find the problem ,sometimes it's ok for just ten mins the sometimes nealy a hour , it's happens when it's hot but the valve clearances seem to be ok , pls any ideas what this could be ????

Likely a dirty fuel pump filter. 

Link to comment
Share on other sites

2 minutes ago, stevethe said:

 

That isn't too likely on a WR. But anything is possible. 

I just hope I find the problem coz I am getin a bit sick ov it now n I love the bike been riding well for ages then had nowt but trouble for 3 weeks now had to put 2 new spark plugs in all ready in the space of 4 weeks and that carnt be normal as I am new to 4 strokes , other than that I love the thing ? All it wants to do is wheelie haha 

  • Like 1
Link to comment
Share on other sites

1 hour ago, stevethe said:

 

That isn't too likely on a WR. But anything is possible. 

It happens. I have a 2008 TE450 that is actually the first year EFI. I have never had a single problem with my bike, but I am good friends with the owner of the Dealer I bought it off. I visit the shop at least once a month. I have seen a few bikes in there that had an ECU units go bad, but not many for how many are out there. If Yamaha has a way to hook it up to a tuner, they will find it.

1 hour ago, Neil Haley said:

I just hope I find the problem coz I am getin a bit sick ov it now n I love the bike been riding well for ages then had nowt but trouble for 3 weeks now had to put 2 new spark plugs in all ready in the space of 4 weeks and that carnt be normal as I am new to 4 strokes , other than that I love the thing ? All it wants to do is wheelie haha 

Just make sure it's hot when they are runing the system check. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

√ó
√ó
  • Create New...