Jump to content

No spark on my pitbike

Recommended Posts

Hi guys I'm brand new to this site and thought I'd give it a try. I have a 110cc loncin pitbike and it has no spark at all. I went to go for a ride, started up second kick no problem and I got a mile down the road and all of a sudden it died and wouldnt start again. I brought it back home and checked to see spark and there is no spark at all. I bought a new plug and still no spark. Anyone know what the problem was? It ran perfectly fine before this, just randomly died. 

Share this post


Link to post
Share on other sites

Carefully check the kill switch and the wires for it all the way back to the CDI unit. Mostly all of them work by grounding the CDI to ground (the frame) when the switch is in the kill position. If that wire is damaged or pinched any where it is likely grounded, preventing spark. Also carefully check the condition of all the wires coming out of the engine side cover from the stator, there could be a broken wire or dirty connection.

Check the condition of the spark plug boot and coil wire. Look for corrosion and damaged insulation. Ignition coils for these are really inexpensive, it can't hurt to just try buying a new one, at worst you'll wind up with a spare.

Could also be the stator, Chinese pit bikes are known for stator problems. You will need a flywheel puller tool, but they are also inexpensive, as are replacement stators. 

Good luck. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×