Jump to content

Water In Dirtbike, Help!

Recommended Posts

Hello! 

I recently cleaned my (KTM 150 SX) and after i wanted to start it. The bike just didnt give me any sign of it wanting to start until after like 10-20 kicks. I got it started with a really deep sound until it spits out oiled water out of the exhaust, It still sounds crappy tho. I take it for a short test ride and it stalls as i let of the throttle but it keeps coming as soon as i give it gas again, I then keep riding and it gets better until it just runs like normal again. At this time i think just a bit of water got in the exhaust when cleaning. 

But later i check the airfilter and under it i find a little bit of dirt and a little bit of water gathered up right in front of the air intake. I dont know if i got water in the exhaust or in the air intake, And if so you know then please let me know if i have to fix anything or if anything might wrong with my bike.

Im just so sad tho, Cuz i bought it about 2 weeks ago and its a complete original KTM 150 from 2009 with 10 hours on it and everything is original, Even tires grips and all there is, 

Thank you! //Emil

 

Share this post


Link to post
Share on other sites

Maybe you got water in both?

Clean air filter. Carb. Drain the oil. Replace with new. Try to start again. Water by itself couldn't have caused much of an issue however if you got dirt in the engine (which would have been tough to go through the filter, carb, reeds) then you may need to disassemble the engine completely to get any possible dirt out. Thos would be my concerns if it happened to my bike.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks! I just took my bike out for a ride today and it runs sweet but i hear ticking noises from the engine, Also changed transsmision oil and fixed the spark plug, As i said bike runs powerful but has a ticking noise, Probably will do a complete teardown on the engine in winter and make everything like new while im at it, Im also starting to think my transsmision might be broken since the ticking noise isnt in the noise of the piston, It gets faster when going faster in whatever gear

 

Edited by William1
Fixed 'typo', one time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×