Jump to content
Sign in to follow this  

2016 Xr650L cold start question

Recommended Posts

Hey guys,had the pig new since last October, great bike,and it splits time with my Gixxer,but after reading and some researching,and just annoying me, I figured I'd finally ask.

 

Regardless of outside temps, the first start,even with a warm up period,I have to feather the throttle,easing off and back on,with too much gas it stalls.

 

This is a every time occurrence,but of course,after the initial startup, it fires fine,and no issues..

 

It fires right up,choke and idles perfect..Just that hesitant feeling of getting gas going it seems..

 

Thanks any ideas and tips guys.

 

Completely stock,and setup done from dealer on purchase.

 

 

Share this post


Link to post
Share on other sites

They're jetted lean to meet emissions standards , which makes them cold blooded until you rejet.

  • Like 1

Share this post


Link to post
Share on other sites

I've owned two and they both behaved differently even with similar jetting.  My current one needs the choke on to start the first time of the day, even when the weather is quite warm.  Normally I can immediately move the choke to the half-way point within seconds and turn it off completely within 10-15 seconds.  Once the engine revs cleanly the first time, I can leave the choke off and it will run cleanly from then on.  Most of the time two or three turns of the throttle and it's good.

The other XR650L was more cold blooded and usually took a couple of minutes before I could rev it cleanly without choke.

You can try a pilot jet that is one size bigger than what's in there now.  You can richen it up a bit with the idle mixture screw.  Both can improve cold running, but make sure you don't go too rich so that you have issues when it's hot.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks fellas, assumed it was jet problem, after reading,figured I'd ask ,even knowing the answer, though I'll try that choke trick and see if it works...Seems ones claim that works,another will chime in doesn't work for them...Fickle creatures on cold start.

Dave's mod, sounds like legit solution,and read many a post of the night and days difference for some, while other have issues on occasion and have contemplated on doing the mods...He's just a change of pace bike,that i enjoy very much,when the back isn't cooperating..

Joe,you still have that RC?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...