Jump to content

Ltr450 won't get spark

Recommended Posts

Any ideas why my ltr450 won't get spark? Just got it this way and the guy has wires everywhere so not even sure where to start. It turns over and has great compression, he said he was riding and it stalled out on him and lost spark IMG_2609.PNG

Share this post


Link to post
Share on other sites

I'd figure out where the wires go to, check to make sure power is getting everywhere, check coil

Share this post


Link to post
Share on other sites
I'd figure out where the wires go to, check to make sure power is getting everywhere, check coil

Coil wire had a short in it making the voltage go all over the place when I tested it. Ordered one earlier so hopefully it helps. Stator tested good, and couldn't find how to test the rectifier or the cdi

Share this post


Link to post
Share on other sites

Sounds like that might be the fix. Otherwise I think a cdi is pretty cheap too

Share this post


Link to post
Share on other sites
Sounds like that might be the fix. Otherwise I think a cdi is pretty cheap too

Cdi is $179 used so hopefully don't end up needing one. Hopefully the new coil solves it. I started going through all the wires today and the only ones that seem to be unplugged are for lights. Going to start organizing them tomorrow

Share this post


Link to post
Share on other sites

Oh jeez yeah I thought it was more like $30-40. Hopefully that new coil will do the trick

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×