Jump to content

Starting problems with Vortex ignition

Recommended Posts

Hi guys

 

having problems getting my bike to start with Vortex ignition, but bike fires up with OEM ECU. Does anyone have any ideas what would be different between the two? Anyone have a good grasp on the Vortex ignition? Once running bike runs strong just doesn't want to start.

Share this post


Link to post
Share on other sites

I would say the vortex might not have the correct mapping. Where did you purchase it from. I've seen this once before but on a 250. Sent it in got remapped and problem solved

Share this post


Link to post
Share on other sites
15 hours ago, Andyb756 said:

I would say the vortex might not have the correct mapping. Where did you purchase it from. I've seen this once before but on a 250. Sent it in got remapped and problem solved

I've had two different people maps and two different complete Vortex's .pretty frustrating!

Share this post


Link to post
Share on other sites

Maybe you have a sensor that is on the verge of failing or high resistance in the wiring and with the oem ecu it will work fine still.

Share this post


Link to post
Share on other sites

The difference is the timing. The Vortex may be using some pretty aggressive timing changes depending on the map. I would look into that first. 

Do you have a data sheet for your mapping? Or any idea who did the mapping, or are you running the factory mapping that comes on the Vortex. 

Share this post


Link to post
Share on other sites

Ok guys this is what I've been able to find out. I sent the ECU to Australia and it tested fine. I had Jamie Ellis of Twisted Development program ECU he knows these Suzuki's well. With the Vortex to set the TPS you push kill button and kick it over trying to start it throttle closed then doing same procedure pushing kill button hold throttle wide open and kick it over trying to start bike this sets the TPS.

i might not have an electrical problem after all. After doing a leakdown test I'm leaking on the exhaust valve side on a head that had the seats cut and new valves with less than 8 hrs, so heads going to come off and see what's going on. This has been a very frustrating problem!

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×