Jump to content

PW80 max revs when starting post carb clean

Recommended Posts

I have a Yamaha PW80 (that I purchased a year ago thanks to your alls help, thanks!) that is hitting max revs the moment it starts.

I cleaned the carb and when reassembling, had trouble getting the slide to go in. I can see the needle going up and down as I twist the throttle. It starts on the first kick but just revs out and I have to kill it.

It has gotten dark so I thought I'd post here so I can finish up tomorrow.

I don't know much about engines... Just relying on my own intuition.

Also, I've installed an oil pump block off so I'm excited for the kids to test some premix out!

Share this post


Link to post
Share on other sites
2 minutes ago, Krannie McKranface said:

Your left crank seal is leaking, sucking in air. Very common. Crank seals should be changed every couple of years, ridden or not.

Well, I put some Boysean reeds on it a few months ago (before the kids got back for break) and while on a back road testing her out, it died. I had the entire top end replaced. I assumed the carb would have been cleaned... So when it still wasn't running correctly, I took the carb off to clean myself.

 

It was fine all week (minus the bogging down) and then after cleaning the carb and reattaching this began. You sure it is a crank seal?

Share this post


Link to post
Share on other sites
Just now, emvee said:

Well, I put some Boysean reeds on it a few months ago (before the kids got back for break) and while on a back road testing her out, it died. I had the entire top end replaced. I assumed the carb would have been cleaned... So when it still wasn't running correctly, I took the carb off to clean myself.

 

It was fine all week (minus the bogging down) and then after cleaning the carb and reattaching this began. You sure it is a crank seal?

Well, yes, it sounds like you have an air leak that you caused, at or in the carb.

Share this post


Link to post
Share on other sites

I've been really busy with work and farm chores...

Got it running tonight and it has a significant power gain after cleaning the carb, however, the throttle slide keeps sticking wide open.

It is like it barely fits - I have to jam it down in the carb. Runs like a champ, but too much throttle and it locks wide open. Like it is just a hair too big.

thoughts?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×