Jump to content

XR650L LED conversion problem.

Recommended Posts

2006 XR650L.  I installed the Tusk handguards with LED signal lights, flush mount rear LED signal lights, and a LED flasher relay.  The result is when I turn on the left or right signal lights, all the signal lights turn on and don't flash.  I then took out the turn indicator light in the dash.  Result is if I turn on the left signal light, the front and rear left signal lights turn on and don't flash.  Same thing if I turn on the right signal light.  Not sure what to do next?

Share this post


Link to post
Share on other sites

I double checked all the connections and they were all good.  I swapped the wires on the relay and walla it works.  Thanks for your help.

  • Like 1

Share this post


Link to post
Share on other sites

glad you figured it out, though this is usually the result of not having a diode in the circuit which lets the signal light flow back through the other side of a light circuit.

not sure if that has anything to do with your issue or not but that's what happened when I did LED turn signals on my 250l. had to put diodes in between both legs of the circuit because the 250l has a 3 wire system (ground, flasher, and DRL) and the lights I used were only 2 wire. if I hooked the DRL and flasher together then you'd get both front and rear signal on solid, if I didn't hook the DRL well...then I didn't have DRLs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×