Jump to content
Sign in to follow this  

Metal shavings and somethings else

Recommended Posts

So I changed the oil on my 2017 ktm250sxf for the second time, it had 34 hours on it. When we drained the oil the drain plug had metal shavings on it. Then once we checked the screen there was NO metal shavings but something weird kinda like real little chunks of glue or rubber. Once we got to the oil filter there was nothing there that shouldn't be. But I heard the metal shavings could be from where the bike was bought new and was just getting broke in. Is that what it is? Or is it not and I need to fix something or just get rid of the bike?

Share this post


Link to post
Share on other sites

Just from breaking in - + little chunks of silicon probably when the cases were put together

Share this post


Link to post
Share on other sites
Just from breaking in - + little chunks of silicon probably when the cases were put together

Okay thanks

Share this post


Link to post
Share on other sites

I'm hoping is wasn't the second oil change it ever had, just the second one you gave it. Post a pic

Share this post


Link to post
Share on other sites

34 hours and you've only changed the oil twice? I'm not trying to be an &%$#@! here, but don't be surprised if your motor doesn't last very long. At 34 hours, you should have changed your oil 6-7 times already (including the oil change after break in).

Share this post


Link to post
Share on other sites

Ya I have the exact same bike and did an oil change/filter change at 1 hour and then every 5 hours after that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

Sign in to follow this  

×
×
  • Create New...