Jump to content

2015 kx250f cant start, wont idle

Recommended Posts

Hello guys, so i changed a piston and ring on my 2015 kx250f, had a few track days, everything was fine untill coming out of corner with low rpms i felt like bike has lost its power, i kicked lower gear and bike went fine till i put in neutral, then it died. Since then i cant kickstart it when its cold and its bogging and spitting, sputterig and dying at low rpms. It can only be started by bumpstart. I'v checked valve clearance, timing, air filter, fuel filter in tank, put in a new spark plug, checked TPS, everything seems fine, any ideas what's wrong with it? I'm running out of clues.. 

Share this post


Link to post
Share on other sites

Lets start from the beginning - but first;

What does the plug look like after running it?

Does it have compression? How much?

 

The basics - suck, squeeze, bang, blow.

As you know your engine needs 4 things to run; a combustible air/fuel mixture, a way to compress it, a way to fire it, at the right time.

What are you missing?

Edited by Trfsrfr

Share this post


Link to post
Share on other sites

Finaly solved this, problem was in fuel pump, it had an o-ring broken and just to be sure its working, i took it out, add to battery and run it a few quick times back and forth, put everything back together and it works, bike feels better than ever

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×