Jump to content

plastic/silicon in carburetor ??

Recommended Posts

I have a yz250f that turns off with any gas but it idles, I opened the carb and found some plastic substance clogging the gas filter it works fine now but does anyone know why this happened ? so i can fix or prevent the problem. thanks.

Share this post


Link to post
Share on other sites
14 hours ago, vicxr400 said:

more info and maybe a pic would help???

i already took all the plastic out and put the carb back

11 hours ago, cjjeepercreeper said:

Common cause is the rubber in the petcock disintegrating.

so i could buy another petcock and fix the problem?

Share this post


Link to post
Share on other sites
10 hours ago, Still Bill said:

There is a filter inside the carb?

yes in the fuel reservoir 

Share this post


Link to post
Share on other sites
10 minutes ago, mottobro said:

i already took all the plastic out and put the carb back

so i could buy another petcock and fix the problem?

If in fact that is what is happening.  Take your petcock apart if it can be disassembled and see if the rubber gasket is disintegrating.

Share this post


Link to post
Share on other sites
14 minutes ago, cjjeepercreeper said:

If in fact that is what is happening.  Take your petcock apart if it can be disassembled and see if the rubber gasket is disintegrating.

i will thanks alot

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×