Jump to content

94 yz250 wont rev past 3/4 throttle

Recommended Posts

my yz250 will idle good and through 3/4 throttle runs alright, not very responsive though. once i get to 3/4 throttle it will start poppin real bad and wont rev any higher. im thinking the main jet is too big, main jet is 340 and pilot is 40. im very new to 2 jokers (my first 2 stroke). it has the mikuni TMX btw. i have checked the reeds and they look great.

 

Share this post


Link to post
Share on other sites
18 minutes ago, THE KRAN said:

Sounds more like a bad stator, unable to make proper spark at high rpms.

You should never have to change jetting, if it ever ran right with the jetting you have now....

in nuetral it will rev out, but when im riding it 3/4 is all i can get out of it. i also dont know if it ever ran right because it was not running when i got it, the previous owner never even rode it he just bought it because he said he couldnt pass up a 94 yz250.

Share this post


Link to post
Share on other sites

Sounds like a stator issue. When in neutral it is easy for the bike to rev out because there is no load on the engine. As soon as you put a rider on the bike and try to go that requires the motor to make power with a weak spark. Don't quote me on this though wait to get some other opinions

Share this post


Link to post
Share on other sites
1 minute ago, zach_507 said:

Sounds like a stator issue. When in neutral it is easy for the bike to rev out because there is no load on the engine. As soon as you put a rider on the bike and try to go that requires the motor to make power with a weak spark. Don't quote me on this though wait to get some other opinions

what is wierd about it is itll bog down bad with the gas on but when i turn it off and run some of the gas out of the carb itll get right on the pipe, and that joker is fast. ever tried riding a yz 250 without a seat?

Share this post


Link to post
Share on other sites
9 minutes ago, yamaturkey12 said:

done they look brand new.

 

See that now my bad

Share this post


Link to post
Share on other sites
8 hours ago, yamaturkey12 said:

done they look brand new.

 

You cannot tell by looking. You need to remove the reed cage, turn it upside down, and pour in some gas. It shoud drip very slowly. Fast means they are shot.

Reeds fatigue before they chip.

  • Like 1

Share this post


Link to post
Share on other sites

Tomorrow, remind me and I'll send pics of ohms readings as far as stator. If me, I would go back to factory settings and go from there! Prior owner.…...well who knows!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×