Jump to content

Kx250 no spark

Recommended Posts

HI everyone!! My name is rocco. I'm I new member of the forum. I bought a 1990 Kx250 back in early January as a basket case. Rebuilt the whole bike, and when I went to start it up for the first time, no spark. I traced it down to the ignition coil so I bought a cheap Chinese coil just to get it going. The ohms for the coil were within spec but still no spark. The coils on my stator were rewound, and the pulse coil's resistance is good, I have a pulse coming from it too. All the stator resistance's are good. So I traced it down to the cdi. Checked all my grounds, sanded them down. Checked all my connections with a test light. I bought a used cdi off ebay, put it on and still no spark. Does there have to be an engine to frame ground? Any recommendations or tips? Thanks, Rocco.

Share this post


Link to post
Share on other sites

Here a drawing from the service manual. Don't see a ground on it other than the coil and CDI being attached to the frame. Wish I could be more help. I had similar problem on my '03 KX250. Cleaned all the connections and made sure they were connected properly. In the end it turned out to be a bad spark plug. Put in a different one and had spark. The plug I was using looking new but simply wouldn't spark. 

 

electrical.png

Share this post


Link to post
Share on other sites

Hi! Thanks for replying. There is a ground that runs from the cdi to the coil. Clean all my grounds good. Checked my connection's. I did teat the spark plug on another bike and it does work. Can't you test a cdi with a test light?

Edited by Rocco H

Share this post


Link to post
Share on other sites

I have looked at that before. I have ordered a new aftermarket cdi for the bike. Like I stated, I bought a cheap Chinese coil just to get the bike going, the cheap coil could be faulty or something.  I purchase 3 used oem coils of of eBay and the are all out of spec. Do you know of any good aftermarket coils?,

Share this post


Link to post
Share on other sites

Ok. Got a high of 58 volts out of the stator, but how do I feel the voltage coming out of the cdi?

Share this post


Link to post
Share on other sites

How do you feel anything? of course you hold the wires. hold both in one hand to keep electricity from going across your heart and blowing your heart up, with blood gushing out of your mouth and filling your lungs as you drown in your own blood.

ha! just kidding. I find it crazy how scared people are about a little jolt of electricity. If you want a big jolt then hold the wire coming out of the high voltage coil, and with the other hand on the engine.

  • Like 1

Share this post


Link to post
Share on other sites

:jawdrop::lol: ya, I couldn't feel anything coming out of the cdi, but can definitelyfeel something coming out of the stator. I have a new aftermarket cdi coming tomorrow. I guess I'll see if it will work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×