Jump to content

Bike dies when braking

Recommended Posts

Hi all, so I've had this problem for about a month now. My 06 dies after hard braking or stoppies. Revs decrease to about 1300 when braking normally. It started happening after I fixed my air leak by getting a metal hotstart nut. I previously had big jets in it(185 55) to compensate for the air leak but I switched to 170 48 afterwards. I've made sure that the float is in spec, bought a new AF screw, changed to multiple different pilot jets, and cleaned the carb many times. It feels like the bike is dying from excess gas because I can sometimes smell it. Also, it gets harder to start when it dies that way. Any ideas?

Share this post


Link to post
Share on other sites

Sound like your float is wrong.  Try lowering it a smidgen.

Share this post


Link to post
Share on other sites

Float is on point. I've checked it multiple ways and found no leaks in it. I took out the mid body gaskets the other day and they don't look good

Sent from my SM-G900T using ThumperTalk mobile app

Share this post


Link to post
Share on other sites
2 hours ago, m3ntor said:

Float is on point. I've checked it multiple ways and found no leaks in it. I took out the mid body gaskets the other day and they don't look good

Sent from my SM-G900T using ThumperTalk mobile app
 

What? You can't 'take them out' without ruining them.  You need new ones.

Share this post


Link to post
Share on other sites

Yeah I took off the mid body when I first cleaned it and didn't realize that taking it out would mean new gaskets. Ordered a set.

Sent from my SM-G900T using ThumperTalk mobile app

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×