Jump to content

Smartcarb users. Help

Recommended Posts

Got my smartcarb and I've only got about 10 minutes of run time on it. It fired right up when I first installed it period followed all the directions and had the choke on when I filled it. Wouldn't idle without a little bit of throttle and it seemed obviously rich. Since then I've done that process three or four times. Which of these times once the bike is warmed up sometimes turning the choke off early and sometimes turning it off late in the warm up. But once the bike dies and it's warmed up I can't get it running again. If it dies when I put on my gear, or if I let it die so that I could lean out the carb the same issue is I can't get it started again. Clearly it's rich and possibly a little flooded. But I'm surprised because it can't be more flooded then when I'm running with the choke on it seems. But I do smell a little gas. I have the queue 07 rod 45 klicks from Rich. Maybe starting fresh the bike isn't flooded and when I start it and really start sucking in the fuel it floods itself and as a result I can't get it started. But I feel like something else is going on because it will kick and chug a couple times and die.

I did message message smartcarb on Facebook and I'm sure they'll respond. But I thought I'd put the question out there for the forum as well. Since the bike will only start when fully cold soaked I only get one or two chances a day to fire it up and mess with it. When I get home from work tomorrow I think I'm going to set it to 50 clicks and see if I can smooth out the startup.

 

For the sake of argument. Assume my bike is in great mechanical shape as it didn't seem to have any problems before I put the carburetor on. I'm well aware of some of the issues if your bike is mechanically sound but before I go tearing into things I'm going to narrow down the settings which I've been told can be finicky. Plus the bike was running decent on the wore out carb I had before.

Thanks guys

 

Sent from my SAMSUNG-SM-G891A using ThumperTalk mobile app

 

 

Share this post


Link to post
Share on other sites

Never dealt with a Smartcarb, only a Lectron - and if I have my facts straight a SC is sort of a Lectron copy, meaning it has a metering rod? Am I correct on that?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×