Jump to content

DRZ400s ProTaper Handlebar Installation - Throttle Tube Problem

Recommended Posts

Hello Everyone, 

I recently set out to replace my stock DRZ handlebars with the protaper contour 1-1/8" bars. I mounted them and everything that I purchased to go on the bars installed nicely besides the motion pro throttle tube. (https://www.motionpro.com/motorcycle/tools/featured/titan_throttle_tubes/) For some reason, this tube doesn't allow the throttle to reset completely. The throttle snaps back to about 3/4 closed, then must be slightly twisted to reach a complete reset. 

If anyone has any suggestions for what to do/check to keep the throttle tube from working incorrectly? I have attached some pics of the stock throttle tube and the new one to show the difference. 

Thanks in advance! 

 

 

IMG_0392.JPG

IMG_0393.JPG

IMG_0395.jpg

IMG_0396.jpg

IMG_0398.jpg

IMG_0399.jpg

IMG_0400.jpg

Share this post


Link to post
Share on other sites

Ill get to work trimming it when I get home this evening, and yes I had the throttle housing installed and took it off for picture taking purposes... 

Share this post


Link to post
Share on other sites

I just installed a Motion Pro "R1" throttle (01-0094). Works great after trimming, but is not as quick as expected. I used a razor blade and some sand paper.

Share this post


Link to post
Share on other sites

I trimmed the motion pro tube to resemble the stock one like you said Hans. Mounted the housing back on and everything worked as it should. Thank you for the help!

I attached a picture of the finished project! (1st of many) :ride:

IMG_0404.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×