Jump to content

07 yz250f

Recommended Posts

hey guys i want to pick some of your brains... i have an 07 yz250f that ran flawlessly until earlier today. every time i slowed to a stop the bike would just cut off. it would ideal fine but when running in 4th and 5th gear would sometime sputter then whenever i went to stop it would die. any idea what might be causing this?

Share this post


Link to post
Share on other sites

Not a lot given to go on.  Could just be simple as needs a new spark plug, or pilot jet cleaned out, or blocked vent tube.

When was the last time it ran?  What fuel do you use?  How long between rides? (Has it sat up for months?)   Is your gas can metal or plastic?  When was the last time you cleaned the carb?  Did you open the bowl drain and petcock and just flush the bowl or check for fuel flow?  Just some of the simple stuff.

Share this post


Link to post
Share on other sites

That's the first thing I would do is empty and clean the fuel tank , lines, remove and clean the carb. Make sure gas can is clean too with fresh, non-ethanol, 90 octane pump gas. Also, you checked the valves / clearances? 

Share this post


Link to post
Share on other sites

Did the fuel screw fall out? Rebuilding my sons wr250f ,when reassembling I forgot to put fuel screw in and was wondering why it wouldn't idle? Fuel screw back in....problem solved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×