Jump to content

04 YZ450F water pump shaft "popping" in/out after new hot rods kit

Recommended Posts

At the end of a total top/bottom end rebuild and looking for advice w the water pump assembly as it fits in the crankcase cover; it doesn't seem normal to me for the impeller shaft (w/ impeller properly torqued 10ft lbs) to "pop" in and out of the right cover. It only moves about 1-2 mm, but when pushed inward (towards the bottom end) and spun it by hand (cover is off at this point) sounds like its contacting the case and grinding.

 

My question to anyone who knows better is; is this normal? After reinstallation of the cover, would the counter balancer keyhole (where the keyway of the impeller shaft fits in) prevent the whole assembly from being "popped" back in towards the case after reassembly?

 

I'm worried that the water pump impeller assembly will start to grind against the case after installation.

The old pump was replaced by me w a new hot rods kits, but never installed on a working engine after. So new impeller shaft, bearing, oil/coolant side seals. The required washer was reused, as was the impeller itself, which shows no sign of it grinding before.

Any advice is greatly appreciated! Everything in this engine is new except for the top end and transmission gears which looked in great shape. I'm excited to breathe life back into it!

Thanks!

Share this post


Link to post
Share on other sites

I believe that's normal. Nothing should push the impeller against the side cover like that when it's all together. If in doubt, leave water pump cover off, install side cover, and make sure everything turns smoothly before putting water pump cover on.

Share this post


Link to post
Share on other sites

Thanks C-P, I tried it w the wp cover off and it doesn't pop out towards the cover when seated in the counter balancer keyway. Good idea, thx!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×