Jump to content

Kx125 clutch issue (1991)

Recommended Posts

I have been racking my brain trying to figure out why the clutch on my 91 kx125 won't disengage. I have replaced pretty much everything but the basket (plates, springs, holder, actuating arm, throw out bearing, pusher) and still nothing. I have been going by the manual (clymer) and everything seems to be correct. I picked the bike up fairly cheap but don't want to cut my losses. Just want to get this up and running for a beater my buddies can ride. PLEASE HELP! Thanx.

Share this post


Link to post
Share on other sites

Does it have the little ball bearing between rod and pusher?  I'm not sure off top of my head with that year but alot of Kawasakishave that. Can fall out easily without knowing 

Share this post


Link to post
Share on other sites

IMG_0734.jpg

Here's the diagram that I'm going off of. There is a bearing that gets pressed into the push plate which is there.

Share this post


Link to post
Share on other sites
7 minutes ago, mjwalker4 said:

IMG_0734.jpg

Here's the diagram that I'm going off of. There is a bearing that gets pressed into the push plate which is there.

Ok nvm doesn't have the bb your arm is in the cover.  When you put the cover on you have to make sure the arm is in correct spot when cover is seated tight.  Sometimes you have to turn arm to left as you're putting cover on so when tight arm is correct spot. Hard to exsplain sry 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×