Jump to content

CR250 rattle during high RPM?

Recommended Posts

Hi all,

I just did a top end on my 2005 cr250. 

Wiseco piston, set ring end gap. Cylinder looked good. 

I rode it at the track last night. A really sandy fast, running the bike hard (after heat cycling it). 

Anyways, occasionally I'll hear almost a rattling sound under heavy load at 1/2-3/4 throttle. 

Could it be chain slap? Noticed my chain was loose and the slider is worn out. 

My concern is if it is detonating but I have no idea what that sounds like. It sounds like a rattle or slap sound right now. 

Also, I noticed one of my power valve cables was frayed. Ordered a new one to put on next week. Could that be a reason for the rattle sound?

Thank you. 

Edited by Patrick Lawless
Add more information

Share this post


Link to post
Share on other sites

Its more than likely detonation or pinging, its always an issue on the 05-07 CR250's.....especially with a nice fresh top end and plenty of compression!

What fuel are you running? Can you get hold of a higher octane fuel like avgas?

Theres plenty of info here on TT about this problem, the majority of 05-07 owners end up getting the head re-cut and excessive squish problem resolved = no more pinging or detonation and a sweet running bike.

Share this post


Link to post
Share on other sites

I would say its detonation also. Try some octane booster from your local moto dealer. I used to run that in my RM250 or it would ping, the booster stopped it. Get booster designated for motorcycle race engines, not wallmart cheap crap.

Share this post


Link to post
Share on other sites

Thanks for the help guys. 

 

I was running 93 pump gas..... I have access to some 110 leaded but it is $9 a gallon. 

 

I will give that a try and see if it improves. 

  • Like 1

Share this post


Link to post
Share on other sites

I put some 110 leaded in it, about 75% 110, 25% 93 octane. Seems to run much better hardly any weird noises. 

 

I do do notice a small slap sound when chopping the throttle which I assume is the power valve closing. I just replaced those cables since one was frayed. 

 

I'll just run the 110 until I can maybe mess with jetting it or just continue to mix the 110 in. 

Share this post


Link to post
Share on other sites

Ok, I have been running a smaller mix of 93 pump and 110 race gas. 32:1 motul 800.

My pilot jet is a 40, Main is 410 (not sure of needle going to check this weekend).

 

It has been running much better, no slapping or weird noises under heavy load (I primarily ride at sand tracks).

 

Only issue is that occasionally coming of a long straight at high RPM, I chop the throttle to brake, then if I hit a bump or need to accelerate more I crack the throttle slightly (maybe 1/8).

 

At that time I hear a rattle sound similar to the detonation I was experiencing earlier but I am not sure..... could this simply be chain slap or something else?

 

It even made that noise rarely with 100% 110 race gas.

 

My next step is to richen the needle one position.......... sorry to keep bothering everyone, I just spent a lot of money on the top end.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×