Jump to content

Recommended Posts

I am looking for advice, my yz250f 2009 has had a issue for awhile now were as I can turn the bike over with my had quite easily. I have yet to do a compression test but am confused, the bike altough low compression does start eventually. easy cold but sometimes first kick hot but other times I'm there got 10-15 minutes. when trying hot it wants to start were it is almost starting everytime but I feel it just needs more compression to start. I have put new spark plug in and jetted carb to where I think it is not longer the problem. no shavings in the oil filter, what should I do ? put new piston and rings in it???

Share this post


Link to post
Share on other sites

I recently adjusted valves, I think it was one intake and one exhaust that were to tight and I reshimmed them. Probably done around 10 hours ago

Share this post


Link to post
Share on other sites

The valve clearances might be in spec but it doesn't mean they're sealing properly

(worn valve faces and seats)

If they've been re-shimmed more than once, they're likely due to be serviced.

  • Like 1

Share this post


Link to post
Share on other sites

From my experience, once you shim stock valves you better get ready to replace. The titanium valves have a coating. Once it wears through and into the titanium they are not long for this world. I've never gotten more than 5 hours or so after reshimming stock valves. If you continue to reshim you run the risk of the outer rim of the valve breaking off and completely destroying everything below. I'm not sure about stainless.

Sent from my SM-T217T using ThumperTalk mobile app

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×