Jump to content

rm125 gearbox issues

Recommended Posts

just been working on a friends 2002 rm125. it has some gearbox gremlins but im struggling to find the issue.

the problem is sometimes when you shift upwards or downwards you have to knock the lever back to its central position . once in whichever gear it doesnt jump out of gear. it feels to me almost like the drum isnt rotating correctly. all gears can be selected eventually.

luckily i have a spare gearbox in good condition.

ive tore the engine down for inspection. shift forks, drum , shafts are all straight. the detent (think its called that) arm is fine too.

as i stripped it i noticed there is a brand new crank in there so someone has split the engine recently.

ive individually swapped parts over and still cant find the issue and its not very often something beats me lol this box has been opened and closed more than a hooker :)

it feels as though the gearbox is locking in place. if i slacken the gearbox drum retaining bolt the problem goes away. so i assumed a washer or shim was missing from one of the shafts but all are where they should be. help! 

Share this post


Link to post
Share on other sites

sorted it guys. the shims were thin compared to the other ones out the spare gearbox. the box must have been binding itself up

Share this post


Link to post
Share on other sites
6 hours ago, sandking11 said:

just been working on a friends 2002 rm125. it has some gearbox gremlins but im struggling to find the issue.

the problem is sometimes when you shift upwards or downwards you have to knock the lever back to its central position . once in whichever gear it doesnt jump out of gear. it feels to me almost like the drum isnt rotating correctly. all gears can be selected eventually.

luckily i have a spare gearbox in good condition.

ive tore the engine down for inspection. shift forks, drum , shafts are all straight. the detent (think its called that) arm is fine too.

as i stripped it i noticed there is a brand new crank in there so someone has split the engine recently.

ive individually swapped parts over and still cant find the issue and its not very often something beats me lol this box has been opened and closed more than a hooker :)

it feels as though the gearbox is locking in place. if i slacken the gearbox drum retaining bolt the problem goes away. so i assumed a washer or shim was missing from one of the shafts but all are where they should be. help! 

Look closely at the shift drum groves.  Bet there's a wear spot on it . I've done a bunch of same era rm 125s most was the drum

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×