Jump to content

Recommended Posts

I'm having an issue with my rear brake and hoping someone can point me in the right direction. I have a 2010 Yamaha xt250 all stock. I had to change the rear tire about a week ago. Since then I noticed my rear brake when I tap on it it stays mostly compressed to where even when not using the brake the disc gets super hot. I have to insert a flat head to release the compression. Next time I tap on it same thing happens. I have pulled the tire off again lube up all the brake cables and even the brake cylinders that compress the brake pads. I'm at a loss of what could be going on. Brake fluid is still full. Ill upload some pics in just a few.

Share this post


Link to post
Share on other sites

I also checked for any back pressure in the brake system and attempted to relieve any by removing the top of the fill reservoir and brake cylinder with no change. First picture is before pressing on brake. Second picture is after pressing and releasing brake twice. The bike will still move and ride like this but disc builds up friction and gets really hot so I have been only using the front brake which works like it should. Once again any help would be greatly appreciated. I also noticed the brake light stays on after using the rear brake until i manually decompress the break by placing a flat head in between the disk and brake pads and gently prying the two apart.

20170908_185228.jpg

20170908_183841.jpg

Edited by Mike1984
added more information.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×