Jump to content

Clutch issues, any ideas?

Recommended Posts

I have been having a strange issue with my clutch that I can't figure out. I noticed these symptoms a couple days after using the clutch very heavily during a ride. My clutch only engages at the last quarter inch of travel (engagement can very slightly). The free play has always been set correctly, no matter how I adjust the cable it also does not make a difference. I went ahead and bought all new friction and drive plates, along with new springs. That did not fix the issue. The clutch basket also has no wear. I can see where the plates ride but if I run my finger along it, I can't feel any grooves in the surface(pictures below). This has me stumped, anyone have any ideas about what I should check next?  

received_1566872293375552.jpeg

received_1566872413375540.jpeg

20170910_194638.jpg

Share this post


Link to post
Share on other sites

I'm not sure I understand. 

When you pull in the clutch, does it begin to disengage immediately?

When you engage the clutch, it only feels connected at the end of the lever stroke ?  That is normal, to me.  It's slipping the remaining portion of the throw.

You might want to try one of these:

 

http://www.motosport.com/product/?adpos=1o1&cc=us&creative=188670676447&device=c&gclid=Cj0KCQjwruPNBRCKARIsAEYNXIjuBcsdCZfmDpIeuqE4ZXq7-TU_w5NO_fa9EQgWl4IONrEjlC5yLr4aAhZIEALw_wcB&key=ARC-Folding-Aluminum-Lever-Combo&matchtype=&network=g&product_id=ARC-LVR-COMBO-1&psreferrer=https%3A%2F%2Fwww.google.com%2F&pssource=true&segment=badger

 

Share this post


Link to post
Share on other sites
5 hours ago, THE KRAN said:

I'm not sure I understand. 

When you pull in the clutch, does it begin to disengage immediately?

When you engage the clutch, it only feels connected at the end of the lever stroke ?  That is normal, to me.  It's slipping the remaining portion of the throw.

You might want to try one of these:

 

http://www.motosport.com/product/?adpos=1o1&cc=us&creative=188670676447&device=c&gclid=Cj0KCQjwruPNBRCKARIsAEYNXIjuBcsdCZfmDpIeuqE4ZXq7-TU_w5NO_fa9EQgWl4IONrEjlC5yLr4aAhZIEALw_wcB&key=ARC-Folding-Aluminum-Lever-Combo&matchtype=&network=g&product_id=ARC-LVR-COMBO-1&psreferrer=https%3A%2F%2Fwww.google.com%2F&pssource=true&segment=badger

 

Let me rephrase. The bike used to reach the friction zone around the half way point in the levers stroke (releasing the lever from the handle bar). Now the friction zone begins at about 3/4's of the way out, sometimes even later in the levers throw. Do you think theres an issue? To me it for sure seems different than it was, suggesting there could be a underlying issue? This has me stumped. I really don't want to get stranded on the road or trail. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×