Jump to content

xr350 (single carb) backfire blasts

Recommended Posts

New to me 85 xr350- single carb. Starts great, responsive on half throttle, can't open it up. After about five minutes it's hot as a pistol with massive backfire blasts (flames!) on decel. Will die after 10mins and need to cool down. It doesn't seem to matter how rich or how lean I adjust things. That only affects starting ability. Here's what I've done: 1. Took the carb apart and cleaned throughly. 2. sprayed all over with starting fluid searching for a leak. No result. What next?

  • Like 1

Share this post


Link to post
Share on other sites

have you checked the valve clearances??? a riding valve can cause the engine to heat up more than it should and if its an intake valve it can cause your bad back fire problem remember things expand when hot and shrink when cold. if the valve adjustment is needed all the time then the valve faces and seats are damaged and need attention.

other than valves ignition timing is usually the cause of bad back firing im not sure if the ignition is adjustable on the 350 most cdi is not adjustable so id check the valves first

good luck I hope you get it sorted

  • Like 1

Share this post


Link to post
Share on other sites

I would start looking at things that, might seemingly, not have anything to do with the problem.

Like exhaust leak at the header/head union.

Something wrong with the jet needle.

Main or pilot jet fallen out.

Did you take out the fuel screw and verify all components present? Verify the fuel screws tip is intact and not broken off.

Loose/corroded spark plug cap/coil wire union.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×