Jump to content

CR 134 build lacks bottom end power?

Recommended Posts

I rode a friends fresh CR 134 national level build and the bike did not have any bottom end and would fall on its face when going from 2nd to 3rd gear. Needless to say something is not right.  

The jetting seems to be spot on so I'm 99% sure it's not the jetting.

420 main

48.5 pilot

air screw 1.5

clip in middle

Has anyone experienced issues with a big bore CR 134?

Thanks!

 

Share this post


Link to post
Share on other sites

If you're used to a 450 it could just be the difference from the two. I know this from experience. It could also be the power valve not hooked up properly. I learned that the hard way on my kids 06. 

Edited by Dklassen

Share this post


Link to post
Share on other sites

Pro doesn't need bottom end doesn't ride it there

Edited by Motox367

Share this post


Link to post
Share on other sites
14 hours ago, Dklassen said:

If you're used to a 450 it could just be the difference from the two. I know this from experience. It could also be the power valve not hooked up properly. I learned that the hard way on my kids 06. 

No, no one was riding a 450.  If you compare it to my sons 17 modded YZ 125 it's a dog.  Under a load it will fall on it's face.

 

Hopefully he will figure it out on the phone with the builder.

Share this post


Link to post
Share on other sites
14 hours ago, Motox367 said:

Pro doesn't need bottom end doesn't ride it there

It flattens out on top requiring shifting.  When you shift it falls on it's face. 

My sons YZ 125 is stronger everywhere.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×