Jump to content

Parts to Replace for Leaking Weep Hole

Recommended Posts

Hey, I have this '09 YZ250F that started continuously leaking coolant out of the weep hole (underneath the water pump housing) while it was running and later while it wasn't running. From some searching this forum, I understand that it's probably a bad seal. So my question is what all do I need to replace to fix the issue and what should I replace while I'm in there?

Here's the schematic https://www.rockymountainatvmc.com/oem-schematic/6

I appreciate any input, thanks in advance!

Share this post


Link to post
Share on other sites

Good luck with it.  And be careful when you remove and reinstall the right side cover.  You have to instal the pump wheel with vanes, leave that cover off, and use it to turn the shaft as you install the cover so the teeth will engage the gear on the crankshaft.  If you just bolt it up and force it on, you can break the teeth off, and that will total the engine when metal get pumped all thru the oil.  BE CAREFUL......

 

Edited by ronbuell
  • Like 2

Share this post


Link to post
Share on other sites
On 9/19/2017 at 10:30 PM, ronbuell said:

Good luck with it.  And be careful when you remove and reinstall the right side cover.  You have to instal the pump wheel with vanes, leave that cover off, and use it to turn the shaft as you install the cover so the teeth will engage the gear on the crankshaft.  If you just bolt it up and force it on, you can break the teeth off, and that will total the engine when metal get pumped all thru the oil.  BE CAREFUL......

 

Alright, I'm not quite following you rn since I haven't taken the cover off yet. But I'll look at it and make sure the gears mesh once I take it off.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×