Jump to content

Someone please help!!

Recommended Posts

I was taking my engine apart to put in a new piston and when I opened the power valve cover on the left side of the bike (1st picture) i seen two screws just sitting in their not connected to anything! I see where they go but they don’t seem to screw in and one has a notch in it and I don’t know if that’s normal... any help would be appreciated! EDIT: when I opened it up oil poured out, is that normal?

IMG_2628.thumb.jpg.ade66158ffe676258c4d630d0daf648c.jpgIMG_1506221482.616524.thumb.jpg.a38b9da02ee98c8459bf5733923c6554.jpg

 

 

Share this post


Link to post
Share on other sites

You're going to need new screws and it wouldn't heart to tap the holes. (Shut up you deviants)..

  • Like 1

Share this post


Link to post
Share on other sites
You're going to need new screws and it wouldn't heart to tap the holes. (Shut up you deviants)..

Do you think it matters what kind of bolts I use? Like if I just go to a parts store and try to match the original ones up with a little bit longer ones?

Share this post


Link to post
Share on other sites

I hate seeing BS like this from previous owners. The original hardware was lost at some point and they most likely use standard SAE hardware instead of metric, whatever they had lying around.

The bolt in the upper left of pic 2 is not right either. They should all look like the bolt in the upper right of pic 2.

Those retainer plate holes are slightly countersunk, so you need a countersunk screw head to properly fasten them. The bolts the PO used are not.

Buy the proper oem hardware.

  • Like 3

Share this post


Link to post
Share on other sites
I hate seeing BS like this from previous owners. The original hardware was lost at some point and they most likely use standard SAE hardware instead of metric, whatever they had lying around.
The bolt in the upper left of pic 2 is not right either. They should all look like the bolt in the upper right of pic 2.
Those retainer plate holes are slightly countersunk, so you need a countersunk screw head to properly fasten them. The bolts the PO used are not.
Buy the proper oem hardware.

I was pretty upset opening this up I just hope the threads aren’t messed up. I ordered the oem bolts from MotoSport

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×