Jump to content

clutch

Recommended Posts

hey on my 1994 ktm 300exc, i just put a new clutch with heavy duty springs in it to see if that would help with the play in the clutch cable

ive adjusted the clutch cable and clutch lever perch as much as i can and it still have an inch of play in the cable

i also just put a new motion pro clutch cable in it and it was shorter than the old one that was on it

how do i fix this?

Share this post


Link to post
Share on other sites

How long have you owned the bike? Has the cable always been like this or just develop?

Since you just replaced the clutch and springs, I'd think you'd have noticed if anything was wrong with the pushrod and/or its engagement with the lever in the case.

Is the clutch lever and perch on the handlebars the stock parts?

Share this post


Link to post
Share on other sites
How long have you owned the bike? Has the cable always been like this or just develop?
Since you just replaced the clutch and springs, I'd think you'd have noticed if anything was wrong with the pushrod and/or its engagement with the lever in the case.
Is the clutch lever and perch on the handlebars the stock parts?

i just got it like 2 weeks ago and it the clutch was bad when i got it so i replaced it
the cable was frayed and it had a shitty clutch perch so i got a new one on there but i adjusted the cable as much as i could and i put washers on the cable so the clutch would engage
the push rod seemed fine, i think that the cable is the wrong size but im not sure

Share this post


Link to post
Share on other sites
12 minutes ago, cr125-trx400x-cr85r said:


i think that the cable is the wrong size but im not sure

That would cause it. Was the Motion Pro cable you put on it a generic cable or spec'ed specifically to fit your model?

  • Like 1

Share this post


Link to post
Share on other sites
15 minutes ago, cr125-trx400x-cr85r said:


i got if off of motorsports.com but i have it as a 1994 ktm 300exc clutch cable so probably is something with that...thanks man

The only Motion Pro cable Motosport shows to have for your bike is the T2. Motosport Item #MOP001W, Motion Pro Item#10-0037.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


×