Dr250 acts like there's no gas

So I was driving about 10 miles down the road with a full tank of gas and had the petcock on 'ON' and as im riding it starts to lose power so I pull over and make sure that my gas is on and as I thought yes it is on but it still tried dying so I put it on RES and it continues to run fine then I start to come back home with it in the ON position and it does the same thing so I put it back onto RES. I don't know what it could be I have a full tank eith only 28 miles on it so far. And I should be able to get at least 120 miles from a full tank

check your petcock filter isnt clogged

3 minutes ago, S.O.A.N.Z said:

check your petcock filter isnt clogged

How do you check? 

drain your tank first

what year / model bike ?

Those fine mesh screens inside the fuel tank can get clogged up with debris.  I had a bike that did exactly what you describe, it wouldn't run in the on position but it would run fine in the reserve position.  That was because the petcock filter screen on the main feed tube was clogged up with junk, but the reserve feed tube was clear as it hadn't been used hardly at all.

1 hour ago, S.O.A.N.Z said:

drain your tank first

what year / model bike ?

93 dr250. Not 100% sure in year

Drain the fuel - remove petcock - the longer tube will be blocked

dr.jpg

14 minutes ago, S.O.A.N.Z said:

Drain the fuel - remove petcock - the longer tube will be blocked

dr.jpg

The longer tube is the regular fuel pickup.  The shorter one is the reserve fuel pickup.

35 minutes ago, S.O.A.N.Z said:

Drain the fuel - remove petcock - the longer tube will be blocked

dr.jpg

Ok thank you

19 minutes ago, GlennRay said:

The longer tube is the regular fuel pickup.  The shorter one is the reserve fuel pickup.

I will keep updated

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now