KX65 Issues

I am looking for opinions, which are usually in great supply here on TT! I am starting to tinker with my sons 65 and am kinda puzzled so far. Below are some symptoms and things I've tried. I am hoping someone smarter than me can give me an obvious direction to head. I have had the carb apart but did not confirm the jetting, I bought the bike used so not sure.

 

When the bike fires up it seems like its hard to "spin up" right off the bottom but once the RPM's are up it seems to run crisp, this is on the stand.

 

When I adjust the air screw all the way in it dies. When are start adjusting it out it will run better until I hit about 1.5 turns, then runs like crap, but once  you hit 2 turns it starts run  better again ? I say run better but this is under no load and is more  that it doesn't cut out when you whack the throttle.

 

It is very hard to start when warm. Seems like it floods easily.

 

Runs pretty strong up to half throttle, with dad on it, but cuts out just above half throttle. Doesn't fall on its' face just misses a bit. If you short shift It's not an issue?

 

Now the big one, for me at least. When I pulled the plug that was in the bike when we bought it and it had a few hours of my son trail riding on it as well as my high speed runs it looked brand new? Absolutely no color on the ceramic? Makes me think the thing is super lean. I have never seen a 2 stroke plug look like that.

 

My plan right now is to put the stock jetting in it if it isn't stock already. Guess we'll see where we go from there. I have checked for air leaks by spraying the motor down with carb cleaner and monitoring for RPM change. I have not checked the main seal yet.

 

Did anyone ever reply to this thread?

 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now