Jump to content

YZ85 Problems.

Recommended Posts

Hey guys I just bought a 2007 yz85 yesterday . It has been doing some interesting things. It doesn't always shift (sticks in gear) keeping in mind this is not running. Also the kickstarter doesn't pivot from being folded you kinda have to force it across the frame in order for it to pivot. Oh yeah the clutch doesn't seem to disengage. Any tips or suggestions would be greatly appreciated. 

Share this post


Link to post
Share on other sites
Hey guys I just bought a 2007 yz85 yesterday . It has been doing some interesting things. It doesn't always shift (sticks in gear) keeping in mind this is not running. Also the kickstarter doesn't pivot from being folded you kinda have to force it across the frame in order for it to pivot. Oh yeah the clutch doesn't seem to disengage. Any tips or suggestions would be greatly appreciated. 

Hey bud... Check out this vid for the kick starter.

Share this post


Link to post
Share on other sites
Hey guys I just bought a 2007 yz85 yesterday . It has been doing some interesting things. It doesn't always shift (sticks in gear) keeping in mind this is not running. Also the kickstarter doesn't pivot from being folded you kinda have to force it across the frame in order for it to pivot. Oh yeah the clutch doesn't seem to disengage. Any tips or suggestions would be greatly appreciated. 

Definitely check the clutch cable and make sure it is routed correctly and not over adj.’d. There should be a couple millimeters of play on the clutch lever. If that’s all good I would lay the bike on its side and inspect the cutch. Laying on its side prevents you from having to drain the oil. But if you plan to change the oil this is a good a time as any.

Share this post


Link to post
Share on other sites

Rock the bike forward and backward when shifting. It's normal for it to not keep shifting if it isn't moving.

Share this post


Link to post
Share on other sites

I've never owned a bike that totally disengaged when not running. I would definitely change oil, who knows what's in there. Once running if it still doesn't disengage the clutch basket is probably notched and will need filed or replaced

Share this post


Link to post
Share on other sites
16 hours ago, ThatE30GUY said:

Hey guys I just bought a 2007 yz85 yesterday . It has been doing some interesting things. It doesn't always shift (sticks in gear) keeping in mind this is not running. Bike must be runnong or it is hard to shift. Or, you need to rock the bike and shift. Also the kickstarter doesn't pivot from being folded you kinda have to force it across the frame in order for it to pivot. I would think it was taken apart and installed incorrectly. Oh yeah the clutch doesn't seem to disengage. Get it running and report back. Any tips or suggestions would be greatly appreciated. 

See bold.

Share this post


Link to post
Share on other sites
21 hours ago, Myboyblue said:


Hey bud... Check out this vid for the kick starter.

 

Hey guys thanks for all the info I got most everything worked out I will change the tranny fluid soon.

Holy run on sentence.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:


  • Similar Content

    • By Koray
      I have just put a new transmission in a 2005 kx85, and everything spins freely while the case bolts arent tightened, but as soon as i tighten the case bolts the transmission and crank suddenly become very stiff and hard to move, what could be causing this?
    • By Ktm520sxrider
      Ready to seal back up





    • By Ktm520sxrider
      Was wondering if anyone knows of a diagram that shows the thickness and inner diameter size for each washer. I think I have it right but I want to be sure. And does it matter what direction the washers face? I'd imagine it does being that each thrust washer has a smooth edge and a sharper edge. I face the smooth edge of the thrust washers outwards if you know what I mean because if they are the other way around it wouldn't seem right. If anyone that has experience with this stuff can chime in that would be awesome

    • By mostexcellentdude
      Hi all,

      Recently bought a 2005 525 EXC with 88 hours/1900 miles. 

      Rode for about an hour just fine until I was on a slow climb, lost all pressure in clutch lever and rear wheel wouldn't release (roll in gear) with clutch pulled in. The bike acted like I didn't have the clutch pulled in. I rolled it down the hill and got it going, but the clutch lever was very hard to pull and shifting was notchy like I was shifting without clutch/rev-matching.

      Got back to truck and lever pull feels good again. Got the bike going like normal for a couple takeoffs, now when I try to take off in first it just dies because the rear wheel wont free up. 

      Can shift into neutral and it rolls around fine. 

      So far I bled the system and refilled with 5W fork oil. Master was full so don't think slave is leaking. Going to pull the clutch cover tonight and see if i notice anything abnormal.

      Any advice on things to look for/test? This is my first time working on the clutch. Any chance this could be a transmission issue? 

      Thanks!! Cant wait to get back on the trail. 
    • By Dylan M.
      Rebuilt my 2015 ktm 250 sx, new crank,piston,bearings,seals,etc. Test rode and it has 1st gear and fifth gear but 2nd,3rd,and 4th is like it's in neutral. Any thoughts before I tear it down again? I'm wondering if it's the shift drum because I kept both shafts in the same sequence when I removed. 
×