Jump to content

17 TE- Motor faliure at 59 Hrs


Recommended Posts

couple months back on my way home from a 2 hour ride my bike lost compression and quit. lucky I was just by my driveway. pushed it back and immediately checked the spark plug and cylinder temps with a temp gun. all seamed fine. pulled reads and pipe. everything looked fine but no compression. pulled the head and found the top of the piston trashed from metal flying around. chunk went down beside the piston and scored the cylinder. bike had 59 hours and 2048km on it. pulled the motor and took it to the dealer for them to decide what happened. chunks of metal looks like bearing cage material but no play or evidence of anything wrong.

the ktm tech found a bunch more chunks of metal in the bottom end but could not find out where It came from. ktm ended up paying for a new head, cylinder, piston, crankshaft and power valve along with all the associated gaskets, bearings and oil seals. total for parts was around 2900$ Cdn. I had to pay Labour as they couldn't find the source. Labour ended up being 730$ Cdn.

motor is back and running great. I was happy with the result as it was 7 months out of warranty having never been back to the dealer with over 2000 km on it.

here are pictures of the top end damage

 

IMG_2847.JPG

IMG_2844.JPG

IMG_2845.JPG

IMG_2832.JPG

IMG_2856.JPG

IMG_2843.JPG

IMG_2841.JPG

  • Like 2
Link to comment
Share on other sites

they never found where it came from so I never got a definitive answer. everything looked intact but it had to have come from somewhere. they agreed it looked like main bearing cage material. carb was fine and air filter was fine. I hadn't taken the air filter out in a couple months as I don't ride in dust.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Reply with:

×
×
  • Create New...